Review: Turn Your Table into a MIDI Instrument with Pulse Controller

So, you've got a drum pattern in your head that you want to get into your DAW, but are lacking a drum pad / MIDI keyboard. Enter Pulse controller which Toby Pitman discovers is a little known gem.  

A little while ago a composer friend posted a link to a really cool looking device. That device was the Pulse Controller. It essentially allows you to turn any surface into a playable MIDI controller just by hitting it. 

Now the idea behind this isn't new as piezo pickups have allowed drummers to trigger MIDI for years, but this requires specialist converters or drum '

For the past 20 years Toby has worked as a professional guitarist, programmer and producer. Clients include Sir Paul McCartney, George Michael, Shirley Bassey, Yusuf Islam, Giles Martin as well as the London 2012 Olympic Ceremonies. He has also worked extensively in TV, Advertising and Film. As well as composing himself he has also ... Read More

Discussion

BenB
Now THIS is an awesome product I'd love to have on the road with me. Even in the studio. As a life long table top drummer, this is killer! Thanks for such a great article!
Rounik
Thanks Toby for bringing Pulse Controller to my attention.

Looking for the "Buy Now" button already...

:)
Rexinator
Toby,
Thanks for the review on the Pulse controller. I picked up one and installed the software, but I'm a bit baffled by what's happening in Logic. I ran the Pulse device into a line input on my Apogee Ensemble interface and selected the proper input in the Pulse Controller MIDI/Audio Setup I'm pretty sure I did the setup correctly (just followed the instructions). The next step in the booklet is to go under MIDI Preferences and enable 'from Pulse Controller 1'. But of course there is no such option in Logic (that I can find). Do I need to set this up in the main Audio MIDI Setup? Or in the Environment? I tried creating an external MIDI track and selecting Pulse Controller 1. I got a live signal, and I could record some MIDI events on that track, but other audio tracks in my project were completely scuzzed out. I've never heard anything like that. I could restore normal audio by deleting the external MIDI track and powering down my Ensemble and then powering it back up. I'm hesitant to use the Pulse Controller until I figure out what the problem was. FYI, I had the buffer size in the controller set to 16 (I'm a fast drummer). Is that too low? Thanks in advance for any insights.
Rexinator
Toby,
After some trial and error, I realized the Pulse Controller is enabled simply by setting the Audio/MIDI Setup and Input Settings correctly. Sorry about the long comment above. However, I noticed a couple of other things that might merit attention. [Again, the device is connected to my Apogee Ensemble interface, and Logic 9 is my DAW.]
1) I noticed that, when the Buffer Size is set to the lowest value (16) or 32, any audio regions that are on other tracks sound very scuzzy during playback. This can can be corrected by turning off or closing the Pulse Controller application. It seems strange that this should occur, because the Audio settings in Logic still indicate a buffer size of 256 (for Logic). If I change the Buffer Setting in the Pulse Controller to 64 or higher, the scuzziness is minimal or absent. This behavior makes for a little difficulty in tapping out fast beats against an existing audio track
2) I also noticed that when I insert a piano instrument or other non-percussion instrument on the software track, it is impossible to play notes in quick succession. It appears that the program requires a Note Off signal before it can accept another note. I tried playing with the Fixed Note Duration, but the only thing that seemed to work was switching to the Choke option. The manual didn't say anything about this behavior, so I was wondering if the problem has more to do with the way MIDI events are handled by the software instrument (maybe something to do with the note duration in the Events list?).
I e-mailed the manufacturer about these questions. Thanks again.

Want to join the discussion?

Create an account or login to get started!